《九阴真经: iOS黑客攻防秘籍》新书发布,干货满满,快来看看吧!

iOS 安全论坛 - 专注于研究 iOS 安全

 找回密码
 立即注册
查看: 164|回复: 6

dpkg -i 安装deb包出错

[复制链接]

3

主题

17

帖子

65

积分

注册会员

Rank: 2

积分
65
发表于 2019-12-19 21:10:33 | 显示全部楼层 |阅读模式
登录ssh,执行dpkg命令手动安装deb包提示如下错误,将deb包制作成Cydia源就可以下载安装,很费解,哪位大佬帮我看看啊!
dpkg -i test_1.0.deb
tar: unrecognized option `--warning=no-timestamp'
Try `tar --help' or `tar --usage' for more information.
dpkg-deb: error: subprocess tar returned error exit status 64
dpkg: error processing archive test_1.0.deb (--install):
subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
test_1.0.deb


回复

使用道具 举报

90

主题

331

帖子

1294

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1294
发表于 2019-12-20 10:24:45 | 显示全部楼层
tar --version,查看一下版本,是不是版本太老了
回复

使用道具 举报

8

主题

42

帖子

173

积分

注册会员

Rank: 2

积分
173
发表于 2019-12-20 12:32:52 | 显示全部楼层
安装其他的deb包有问题吗?还是说只有这个包有问题?如果只是这个包有问题可以发我试试。
回复

使用道具 举报

3

主题

17

帖子

65

积分

注册会员

Rank: 2

积分
65
 楼主| 发表于 2019-12-20 19:45:15 | 显示全部楼层
exchen 发表于 2019-12-20 10:24
tar --version,查看一下版本,是不是版本太老了

tar --version
tar (GNU tar) 1.17
Copyright (C) 2007 Free Software Foundation, Inc.
License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
回复

使用道具 举报

3

主题

17

帖子

65

积分

注册会员

Rank: 2

积分
65
 楼主| 发表于 2019-12-20 19:45:50 | 显示全部楼层
lion 发表于 2019-12-20 12:32
安装其他的deb包有问题吗?还是说只有这个包有问题?如果只是这个包有问题可以发我试试。 ...

试了其他的deb包都不行
回复

使用道具 举报

90

主题

331

帖子

1294

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1294
发表于 2019-12-20 21:22:55 | 显示全部楼层
蚂蚁吃象 发表于 2019-12-20 19:45
tar --version
tar (GNU tar) 1.17
Copyright (C) 2007 Free Software Foundation, Inc.

你这个 tar 是 2007 年的版本,太老了,升级一下 tar 再试试吧
回复

使用道具 举报

3

主题

17

帖子

65

积分

注册会员

Rank: 2

积分
65
 楼主| 发表于 2019-12-22 17:13:22 | 显示全部楼层
感谢老大,升级tar就可以了,在Cydia重新安装tar不行,不过我从12.4系统上复制一个tar替换上就可以了,这回是新版本
  1. tar --version
  2. tar (GNU tar) 1.30
  3. Copyright (C) 2017 Free Software Foundation, Inc.
  4. License GPLv3+: GNU GPL version 3 or later <https://gnu.org/licenses/gpl.html>.
  5. This is free software: you are free to change and redistribute it.
  6. There is NO WARRANTY, to the extent permitted by law.
复制代码


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|iOSHacker

GMT+8, 2020-1-21 04:50 , Processed in 0.052561 second(s), 19 queries .

iOS安全论坛

© 2017-2020 iOS Hacker Inc.

快速回复 返回顶部 返回列表